Using PSAppdeploytoolkit with MDT2013

Hi does any use PSAppdeploytoolkit with MDT 2013?

I’ve tried it a couple of time but install script that work in the LIVE environment via SCCM2012r2 or manually generally fail for one reason or another when executed as part of an MDT Task Sequence.

Can somebody explain why it doesn’t work or provide information on how they successfully use PSAppdeploytoolkit with MDT 2013. It would be nice to know if it’s possible or if I just need to accept I have to create wsf installers for use with MDT in addition to the PSAppdepolytoolkit installers.


Hey Angus. I’ve been using PSAD for quite some time now as part of our MDT 2013 Task Sequences with great success.

For starters, if you run the packages outside of an MDT 2013 Task Sequence do they work? If no, there’s a package problem that’s not related to MDT but the package itself and that will need to be corrected first before we can continue.

Second, can you upload your OSD logs, specifically smsts.log and BDD.log, for review?

Finally, there are a few different approaches to doing this and depends on your environment. Our application source files live on a DFS share that’s accessible to all users. As such, we created applications in MDT that basically run the .PS1 from the network location WITHOUT importing all the application files into MDT directly.
Its late (1:11AM) and I’m guessing I’m not explaining it well so take a look at this photo for an example package we’re currently using. And as the screenshot suggests, the core PSAD files all live in C:\PSAD on EVERY machine that’s imaged. In fact, that’s the first thing that gets copied over after the WIM is laid down.

Not to toot my own horn, check out my post here on Centralizing the Toolkit which has a bit more information on how we’re successfully handling application installations. It includes a better high-level overview than what I’ve [tried to] explain here.