Visual Studio Silent install

Hello guys,

I am trying to install via intune Visual Studio 2022.

Before releasing the package, I tried installing the software from the command line on my test pc.

unfortunately when i try to start the setup it returns an error message 87.

Execute-Process -Path "$dirfiles\vs_setup.exe" -Parameters "--quiet --nocache --wait --in "$dirfiles\CustomInstall.json" -WindowStyle Hidden

If I try to use the command from cmd instead, I have no problem.
e.g. vs_setup.exe --quiet --nocache --wait --in "$dirfiles\CustomInstall.json

what can I do?

Thank you a lot

The problem is that you did not escaped the double quotes with back-ticks ( ` )for your -Parameters. Try this instead:

Execute-Process -Path "$dirfiles\vs_setup.exe" -Parameters "--quiet --nocache --wait --in `"$dirfiles\CustomInstall.json`" -WindowStyle Hidden

Thank you for your reply.

if I try with the command you provided I still get an error because it doesn’t find the closing of the (")

so, i’ve i put an other (“) and the installation has started:
Execute-Process -Path “$dirfiles\vs_setup.exe” -Parameters “–quiet --nocache --wait --in "$dirfiles\CustomInstall.json”” -WindowStyle Hidden

thank you for your support.

have a nice day :wink:

I did NOT said to do “” I said to do `"


ok I don’t know why… the important thing is to have solved it :slight_smile: :wink: