Silent installing with custom parameters (InstallShield quotes thing)

Howdy. First time posting here.

I’ve been fighting with some education software for a couple days and I’m clueless on what could be going on.

I’m trying to send over a Licence key to the installer, which is an MSI disguised inside an InstallShield wizard. Here’s the command :

Execute-Process -Path "$dirFiles\PASCO_Capstone-" -Parameters "/S /V"/qn LICENCEKEY=xxxxx-xxxxx-xxxxx-xxxxx-xxxxx-xxxxx DISABLE_SOFTWARE_UPDATES=1"

(Referencing this post : Silent Install asks for input (InstallShield Quotes issue))

I’ve tried multiple options and it results in :slight_smile:

  • The Windows Installer window shows up.
  • The command failed because it thinks that the double-quote ends the Parameter field.
  • The installation goes thru but doesn’t apply the parameters.

Their documentation about installing with the License key included (notice the spelling mistake XD)
Install PASCO Capstone license key with a command line switch (Windows) - Knowledge Base | PASCO

PASCO_Capstone-x.y.z.w.exe /s /v"/qn LICENCEKEY=< My_Key > DISABLE_SOFTWARE_UPDATES=1"

They do specify using cmd here but I would like to still use Execute-Process unless it’s fine running a cmd.exe

What do?

Look here (Silent Install asks for input (InstallShield Quotes issue))

Or wait until tomorrow and hope I remember to help you

1 Like

I’ve given the thread a good read and tried the formatting that you suggested and it didn’t seemed to work for me.

I might suspect it’s an issue for the installer itself.

I’ve noticed that in a past installation script of the application, the /v was inside of the quotes but it did seem to work correctly.

The original version we installed is 32-bit but the newest version is 64-bit.

I got to note furthermore that there was an auto-updater available for the software but one of my colleagues was getting a particular error when upgrading.
It was something like:

The file is not marked for installation.

Again, the provided instruction on their website only assumes doing it thru CMD. I might just try opening up a CMD in PSADT and installing it that way…

I gotta contact their support team before I decide doing so because this is just a big mess. :expressionless:

This will work in CMD because you do not need to escape double quotes after the /v:

PASCO_Capstone-x.y.z.w.exe /s /v"/qn LICENCEKEY=< My_Key > DISABLE_SOFTWARE_UPDATES=1"

This will not work in PSADT because:

  1. The double quote in /V" inside the double quotes for -Parameters is not escaped
  2. You have an odd number of double quotes. The /V" and -Parameters cannot share the double quote at the end
Execute-Process -Path "$dirFiles\PASCO_Capstone-" -Parameters "/S /V"/qn LICENCEKEY=xxxxx-xxxxx-xxxxx-xxxxx-xxxxx-xxxxx DISABLE_SOFTWARE_UPDATES=1"

This will work in PowerShell / PSADT:

  1. The double quote in /V" is escaped with a backtick
  2. /V" now has its own double quote at the end and it is escaped with a backtick
Execute-Process -Path "$dirFiles\PASCO_Capstone-" -Parameters "/S /V`"/qn LICENCEKEY=xxxxx-xxxxx-xxxxx-xxxxx-xxxxx-xxxxx DISABLE_SOFTWARE_UPDATES=1`""
1 Like

This is a really well done solution and explanation @That-Annoying-Guy.
Thank you very much.

So I’ve tried that and it is still failing to add the licence. I will suspect at this point there’s an issue with their installer.

I’ll get this issue resolved by next week so I consider the case closed.

First verify if the install command works from a basic CMD prompt.

Also, Installshield exes that take those switches rather than /f1 /f2 are MSI wrappers. You could extract that MSI and install it with a transform to set the license as an alternative solution.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.