SCCM Error 60008

On some devices, I encountered error 60008 while running a script with PSADT (PowerShell App Deployment Toolkit). Despite trying various troubleshooting steps, including restoring health with DISM, using System File Checker, updating and installing .NET and PowerShell components, and removing non-native components, the issue persists. Are there any additional suggestions or alternative approaches to resolve error 60008 within the PSADT script?

Error 60008 only occurs when Deploy-Application.ps1 cannot dot-source AppDeployToolkitMain.ps1.

On those machines, either

  1. AppDeployToolkitMain.ps1 does not exist
  2. Deploy-Application.ps1 is running as a user which has no read permissions to AppDeployToolkitMain.ps1.
1 Like

Hi, These two items have already been validated, we tested the package on another machine and it works without any issues.

I just ran into this error today.

It was caused by AppDeployToolkitExtensions.ps1 failing to load.
AppDeployToolkitExtensions.ps1 is loaded by AppDeployToolkitMain.ps1

1 Like

What was done to resolve the failure ?

I fixed the issues in AppDeployToolkitExtensions.ps1.

I had encoding issues.

1 Like

New packages were created in PSADT in various versions and the situation remains, thus excluding the possibility of the AppDeployToolkitExtensions.ps1 file being corrupted. Are there any other alternatives to solve this issue?

what does the log file say?

This is what appears to me when running manually.

What would the log be? If I run the package manually through power shell it doesn’t generate any logs, if I run it through software center the same error appears in “AppEnforce”

Are you using WDAC?

There is a known issue

1 Like

Application blocking by Windows Defender has already been validated, this is not it