Remove-MSIApplications not running when Deploy-Application.exe is called

I am writing a simple script that installs and Uninstalls an MSI. If I run the Remove-MSIApplications command manually it executes without a problem, but if I run
Deploy-Application.exe -DeploymentType "Uninstall"
the script runs and the logs show it completes without error but Remove-MSIApplications didn’t actually run, and the application is still on the machine.

I am testing this with the latest version and noticed that when running Deploy-Application.exe and not specifying the deployment type it would not default to install but instead run the install and uninstall one after the other.

If I remove the installation commands and just leave the uninstallation commands I can run Deploy-Application.exe -DeploymentType "Uninstall" and it executes as you would expect.

Anyone seen anything similar or have advice?

Not sure if this was you, but there is a similar report here:

Issue with 3.10.1 : r/PSADT (

I can’t see how this would be triggered, so if it’s still unsolved, please could you post your script content?

1 Like