PowerShell Minimum should be 3.0?

We have been using the toolkit for all of our application packages with SCCM. We have stumbled across some older Win 7 devices that had PowerShell 2.0. The script errored immediately saying it couldn’t recognize some of the cmdlets. We had to push PowerShell 5.1 (rather than pushing 3.0) in order for the install script to work. We have confirmed the toolkit works with 3.0, but obviously does not on 2.0. Should the documentation be updated to the proper version of PowerShell that has been tested?

Hey there.

We had some issues with 3.8 and PowerShell 2.0 which should be resolved in 3.8.1.

We aim to be fully compatible back to 2.0 for PSADT 3.x. This will change in PSADT 4.x