Error with app deployment toolkit

Hello Team,

We have windows powershell version 2.0 in our environment. Whatever application we have created using PSAppdeployment toolkit does not seem to be compatible with windows powershell version 2.0.

And the installation is failing with the error “The application was not detected after installation completed”.

and we found out that there is powershell version 2.0 compatibility issue with the version PSAppdeployment toolkit we use.

  1. Kindly tell us which version of PSappdeployment toolkit is compatible with powershell version 2.0

2.And let us know how install Powershell 2.0 or downgrade latest powershell version to powershell version 2.0.

Thanks.
Kishore