Chrome fault install

Hi guys,

I tried to install chrome from intune. the installation completed successfully but I can’t see the icon and if I try to search for the program folder I can’t see it in any directory.

i tried using both “execute-process” and “execute-processAsuser” command.

I point out that the problem is present even if I start the installation from powershell locally

Has anyone had the same problem yet?


I don’t think Chrome Installed at all.

  1. PSADT launches Chrome’s Setup.EXE
  2. Setup.EXE fails but returns exitcode 0 to PSADT
  3. PSADT assumes the install went OK.

When I see this, I add a sanity test in the PSADT script after the install to make sure it did indeed install Chrome and not just lie to me. In this case, add a check for the \Program Files\ folder. And stick with the execute-process function.

As to WHY this is happening? Force the Setup.exe to create a log file.
I do this for all my packages.


yes it is probably as you say. In attachment I upload the log, created during the installation phase. is blocked at my work due to security. Pastebin seems to be less of a security issue.

sorry… to you

The MSI log file looks like a successful install.

Please note that the Chrome MSI launches an embedded Setup.exe that does the actual installation.
IOW: the MSI is used a wrapper for the Setup.exe. (FYI: Firefox does this too)


  1. Action ended 17:30:51: InstallFinalize. Return value 1.
  2. Action ended 17:30:51: INSTALL. Return value 1.
  3. Property(S): UpgradeCode = {C1DFDF69-5945-32F2-A35E-EE94C99C7CF4}
  4. Property(S): UNINSTALLCMDLINE = C:\Program Files\Google\Chrome\Application\108.0.5359.125\Installer\setup.exe
  5. Property(S): UNINSTALLCMDARGS = --uninstall --msi --system-level --verbose-logging

This means Setup.exe might have its own log file. The real one.
googling for it

Did the computer already have Chrome installed before you tested?
IOW: did you need to uninstall Chrome before you tested your package on this computer?

Note this is now a Chrome installation issue. not a PSADT issue.

hello guys,

I solved the problem. I had basically listed these processes as ones to close/block:


then doing several tests I noticed that he starts the process “setup.exe” and probably also starts googleupdate.exe.

So he would start the msi first however then when he unpacked it and started googleupdate.exe he would close it and the installation would stop.

I then removed googleupdate as one of the programs to close and lock the installation was successful

thank you guys

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.