Beating my head against the wall with this install

hoping someone could lend me some insight.

I am trying to install these two installs (Checkpoint tools for PPC). Both of them are msi’s and it’s just newer versions then what people already have installed. Here is the problem. When it installs the two, it leaves the old version still installed which causes errors when using the software. So I’ve tried throwing in the pre install the uninstalls there, no luck. I tried doing it in the post install and same thing. I’ve used these commands in either place and no luck.

get-package -name "checkpoint tools for ppc" | Uninstall-Package -force
get-package -name "checkpoint tools for ppc (64-bit)" | Uninstall-Package -force

Start-Process "C:\Windows\System32\msiexec.exe" -ArgumentList "/x {C2ECBFBB-CB65-4C9C-8E60-F752506092E1} /qn" -Wait
Start-Process "C:\Windows\System32\msiexec.exe" -ArgumentList "/x {113400DB-D3E3-4E84-91C4-5A2750F98E1C} /qn" -Wait

I’m not sure what else to do. The other gotcha is that all office apps have to be closed when doing the install. I’ve used PSAPP Deploy Toolkit to install other apps with Intune and have had no issues. I am just stumped on this one. any ideas would be greatly appreciated.

I would:

1- Place a delay between uninstall old and install new.

2-Use Execute-MSI -Action Install instead of Start-Process

3- add logging to the MSI installations

Instead of using the 2 “get-package” lines, use this:
Remove-MSIApplications -Name 'checkpoint tools for ppc'


Doesn’t work for this :frowning:

What does the log say?

1 Like

It gave me this error in the log file
MSI (c) (C0:4C) [12:10:47:238]: Failed to grab execution mutex. System error 258.

This software for reference was installed from on prem group policy.

“Failed to grab execution mutex” means another MSI install is happening at the same time as PSADT’s.

What doesn’t make sense to me, I can reboot the computer, log in, and try the script and get the same thing in the log file. I can close out and go manually uninstall it from control panel no problem.

Are you still using GPOs to install software? (Even unintentionally)

If Intune and GPOs try to install an MSI, only one will be successful. The loser gets MSI error 1618.
With PSADT, if MSI if busy with another installation, PSADT will retry the MSI after 10 minutes. If unsuccessful, only then will PSADT gives up with error 1618.

for the closing all office apps gotcha, run this and add what may be missing to the list of both processes and the -CloseApps portion

if (get-process WINWORD, EXCEL, OUTLOOK, ONENOTE, POWERPNT -ea SilentlyContinue) {
Show-InstallationWelcome -CloseApps ‘WINWORD,EXCEL,OUTLOOK,ONENOTE,POWERPNT’ -AllowDefer -DeferTimes 3 -PersistPrompt -BlockExecution