AppDeployToolkit 3.70 not creating logs


I have been using the 3.6 version of the AppDeployToolkit and it has been outstanding. I would like to test the new version as I am having issues in Win 10 with Show-InstallationWelcome and prompting to close applications with 3.6.

We have a nonstandard location for logs (c:\windows\installlogs), so I made 3 changes to AppDeplolyToolkitconfig.xml:

I changed the Toolkit_LogPath to $envWinDir\InstallLogs
I changed MSI_LogPath to $envWinDir\InstallLogs
I also changed Toolkit_LogWriteToHost to True (a preference of ours)

The rest of the .xml is unchanged from the source.

To toolkit is not generating an install log at the location I entered, or anywhere for that matter.

Any ideas would be appreciated.

Thank you.

You need admin rights to write to that location. Is the script running with admin rights?

Yes. As I said, I’ve been using the 3.6 version of the toolkit for some time. I opened the .xml I use for 3.6 and replicated the settings (the three I mentioned) in the 3.7 .xml. 3.7 is really being a pain for me. It’s not passing msiexec parameters, specifically transforms, properly. I discovered the issue of not creating logs when I went looking for the log. I ran it as I run my 3.6 scripts, which still run ok.

Have you run a 3.7 script in debug and stepped through the Write-Log function?

Went back and edited the .xml with notepad instead of Primal Script and it’s working now. Primal Script must be doing something to the .xml.

Thank you for the replies.