Windows Cannot access specified file error

New system admin here. I was trying to deploy 8x8 exe application in an Intune wrapper with the help of PSADT. I got all the configuration created, however, when i deploy the application I get the following error, would somebody able to help? Thanks in advance.

image

I still new to Intune but maybe others can help.
We may need to know more information like the commandline used to launch PSADT in Intune.

Thank you currently using the following command to deploy the app

powershell.exe -ExecutionPolicy Bypass .\Deploy-Application.ps1 -DeploymentType “Install” -DeployMode “NonInteractive”

Hmmm,
From the screen grab, I suspect that the path that is being searched for the file “C:\Windows\IMECache<Intune_application UID>.…” may not have required rights for the user running the install.

Are you installing this in the user context or in the SYSTEM context?
On the Add App screen:

Personally wouldn’t use the Powershell command as the Install command, instead I’d use :
ServiceUI.exe -Process:explorer.exe Deploy-Application.exe -DeploymentType "Install"
and for the uninstall:
ServiceUI.exe -Process:explorer.exe Deploy-Application.exe -DeploymentType "Uninstall"
N.B. I use the ServiceUI.exe (Obtained from MDT - https://www.microsoft.com/en-us/download/details.aspx?id=54259) to bring any dialogs, messages etc through to the User Context

Currently, installing with the context of the System. Just tried the “ServiceUI” method and unfortunately am receiving the same error.

OK, With the dialog still showing (I.E. before Intune has cleaned up the folder structure at the end of the install attempt)
Can you check that the file it is looking for (..\Files\work-64-exe-v8... ???) exist in the path it is reporting?

  • If it doesn’t, does it exist in a different path (above the ..\Files\ folder? for example) - It may be that your packaging script / method has not put this file in the \Files\ subdirectory.
    This is a good reference: 🗃️ Extracted Archive · PSAppDeployToolkit
  • If the file does exist what are the permissions on the file?
1 Like

Just checked the folder on “C:\Windows\IMEcache” and the install file along with the PSDAT file exists within the system. All devices are set with Administrator rights so the system should have admin access to perfrom this function unfortunately running into the same error.

So to clarify - (Assuming you are using the very latest installer) The file work-64-exe-v8.9.2-5.exe exists with in the following folder: C:\Windows\IMECache\00d81d4e-720d-44be-b1a4-75659aa072fb_1\Files\ once deployed to a device (before the installation has cleaned up)?

I have had a brief read of this page:

It appears the .exe install is for user based installs - which you have confirmed is not how you are installing, you stated you are running the install as system, so this is the incorrect way to install it.
You should instead be using the MSI installer (linked on the same page above)

N.B. This provides some additional guidance for the MSI commands for the 8x8 installer:

I hope this helps a little

1 Like