Java Deployment configuration issue

I’m having the worst time trying to make the Java Update window stop popping up for people in my company. We have to instruct them to click “do not ask again” and “later” very frequently and if they click update or block, it causes a ton of issues and extra work for me.

When we do our java updates, we intend to deploy them with SCCM, and none of the users are admins, so they cannot update even if they wanted to. I want to find a way to disable that popup in IE asking if they want to update Java to where it’ll automatically assume “later” and to never ask.

I’ve tried some registry entries that I’ve read about that did nothing (HKLM/SOFTWARE/JavaSoft/Policy) and I’ve tried the C:\Windows\Sun\Java\Deployment files and they seem to not even be trying to work.

I’m lost and this has become a super time consuming issue for me. Any help is super appreciated.

Note: we only run 32 bit Java due to some website we used that won’t work with x64.

Instructions only say to create a JavaSettings.cfg file containing this:

I then use it like this:

Execute-Process -Path "jre-8u341-windows-i586.exe" -Parameters "INSTALLCFG=$dirFiles\JavaSettings.cfg /L $logTempFolder\jre-8u341-windows-i586_EXE.log" -ContinueOnError $false

but like you, this didn’t work so I added this:

Write-Log "Disable Auto-update FOR REAL"
Remove-RegistryKey -Key "HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Run" -Name 'SunJavaUpdateSched' -ContinueOnError $true

And makes Oracle Java stop being annoying.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.