How to deploy using execute-msi?

I’m trying to deploy a msi with parameters. I’ve used this tool wonderfully with exe files, but for the love of me I can’t figure this part out.

I started with a fresh psappdeploytoolkit.

My installation task is as follow

Execute-MSI -Action ‘Install’ -Path ‘ciscowebex-39_1_4_5.msi’ -AddParameters 'SITEURL=" OI=1 IE=1’

When I run deploy-application.exe, nothing happens. No welcome screen, no installation. Is my formatting incorrect?

In my experience if running deploy-application.exe doesn’t start with at least the Welcome screen then you’ve made a syntax error in your script. Usually for me this means I’ve left out a quotation mark somewhere or forgotten to use an escape character when I want to nest double quotes.

In your Execute-MSI line I have added a double-quotation around the SITEURL and converted the smartquotes in to regular single quotes.

Execute-MSI -Action 'Install' -Path 'ciscowebex-39_1_4_5.msi' -AddParameters 'SITEURL="" OI=1 IE=1'

There may also be other syntax errors in your script. In particular check that you haven’t left any open quotes in the script variable declaration section or on the Show-InstallationWelcome line.

I actually already have it. I gave it another test run and this time it worked. Odd. Thanks anyways.