Hi all,

I’m new to the toolkit so I may miss something here :wink:
I’m trying to install a msi file through the toolkit.
My simple line is:

Execute-MSI -Action Install -Path ‘pacakge.msi’ -Transform ‘package.mst’ -Parameters ‘/QN’

pls ignore the quotes. I tried all quote possibilities so far.
The problem is, that the mst file is completely ignored. I’m sure that the MSI file itself is fine. I can do a working installation through the command line. So that’s fine.
However the log always tells me:
<![LOG[[Installation] :: Executing [C:\Windows\system32\msiexec.exe /i “D:\package\Files\package.msi” REBOOT=ReallySuppress /QB-! /L*v “C:\Windows\Logs\Software\packages.log”]…]LOG]!><time=“09:43:35.451120” date=“07-26-2018” component=“Execute-Process” context=“domain\user” type=“1” thread=“2156” file=“Deploy-Application.ps1”>

Regardless what I’m doing it is never using the mst file. I did some research and found a bug the zero touch installer is ignoring the mst or something like that. Is this still an issue? Does the depend on the OS?

Any help would be great!

Best regards,


By the way… the button to register through google is broken on this page. The link ends up with a 404 page.

Ok, I found it out by myself.
I mixed things up here. The script detected my MSI as zeroconf msi and started the process. But I gave the mst file the wrong name so that is could not be identified by zero conf. And because I didn’t understand the process completely I tried to execute my own msi command below the zero conf but this never had a chance to be called because zero conf failed…
As I understand it now I could run my own msi execute without zeroconf and after renaming the mst file to the corresponding msi file zeroconf did the complete installation for me without anything form me.

So, thanks to myself for that enlightenment. Maybe this helps someone else :slight_smile:

But the site owner should take a look for the google registration :wink: