Exe uninstall problem

Hello - new to PSDAT

I have a exe that I can get installed correctly using

Execute-Process -Path "MekkoGraphics.exe" -Parameters '/s /v"/qn ACTIVATIONFILE=C:\staging\Activation.xml" /f1"C:\staging\setup.iss" /f2"C:\staging\MekkoGraphics.log"'

This is working properly.

I cannot get this to uninstall clean. Tried both below -

The first line will say success in PSDAT but nothing actually happens. The second one will rip out part of the app but not a clean/full uninstall.

Execute-MSI -Action Uninstall -Path '{B029C590-07B6-47BB-A094-5272B8BF0093}' -Parameters '/QN'
MsiExec.exe /X{B029C590-07B6-47BB-A094-5272B8BF0093}

Any help would be appreciated.

Same result when running below. PSDAT runs, says uninstall complete.

Remove-MSIApplications -Name "Mekko Graphics" -Parameters /qn

It gets partially uninstalled. The app is an office plug-in. So loading powerpoint kicks off the error that the app is no longer there. But the app is still listed in App - Installed Apps and remnants are in the registry. So if I try to run the installation again it will fail thinking its already installed

In Registry

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield_{B029C590-07B6-47BB-A094-5272B8BF0093}

I see this


"C:\Program Files (x86)\InstallShield Installation Information\{B029C590-07B6-47BB-A094-5272B8BF0093}\setup.exe" -runfromtemp -l0x0409  -removeonly

Should I be using this line above? And if so what command should I use - thanks

Yea, installsheild likes to use GUIDs even for non-MSI packages.

The package you installed wa probably an InstallScript exe

So, yes. The uninstall string in the registry is what you need to use to uninstall.

I have a post on Installsheild packages here

1 Like

Thanks!

Ran the setup.exe /r to make a new iss file for the uninstall. Works perfectly now. Thanks!

-Parameters '/s /v"qn" /f1"uninstall.iss" /f2"log"
2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.