Error message when installing when user is logged on

xml%20config%20file%20error%20message

I got the error message [PSAppDeployToolkit] has an XML config file option [Toolkit_RequireAdmin] set to [True] so as to require Administrator rights for the toolkit to function. Please re-run the deployment script as an Administrator or change the option the XML config file to not require Administrator rights when deploying a script through SCCM.

This only happened on 4 users computers.

Why would this message come up on the four computers. None of the users have administrator rights. The default client settings is SCCM are correct.

This is the first time I have deployed with having the user logged in and am dazed and confused by this :slight_smile:

Thanks,

Donna

Hi, Donna. In SCCM, if the Application’s installation behavior (on the User Experience tab for the Deployment) is set to “Install for user”, this message would make sense (similarly, if Visiun is in SCCM as a Package, the relevant setting would be under the Program, then the Environment tab, then “Program can run” > Only when a user is logged in).

As the PowerShell message indicates, the default setting in the PowerShell script is to require admin rights to run, so if the application or package is installing in the User context, and those particular users don’t have admin rights, then they’d see the message.

To eliminate the message, go to the XML config file for the PowerShell script (in the AppDeployToolkit folder), find the Toolkit_RequireAdmin node, and change True to False.

Hope that helps!