Error during deploy SapGUI

Hello guys,

i’ve tryed to deploy SAP 7.60, but during the installation received this error:

I have no idea what it could be. I tried changing several settings but could not solve the problem.

p.s. if i click on try again, it install correctly the software, but I would like to create an automated installation, never error…

thank you in advance

Please tell us at least your commandline.
We’re deploying SAPGUI with NwSapSetup.exe /noDlg with no issues.

How’s your commandline or Deploy-Application.ps1?

Kind regards

1 Like

Hello BaBa,

sorry for the delay.

this is the command line on the script *.ps1

$returnCode = Execute-Process -Path “$dirFiles\SAPGUI_760_PL9_HF1.exe” -Parameters “/silent” -WindowStyle ‘Hidden’ -Passthru -IgnoreExitCodes ‘*’

while in the sccm->tab (installation program) this is the command line:
C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -ExecutionPolicy Bypass -Command “& { & ‘.\Deploy-Application.ps1’ -DeployMode ‘Silent’ -AllowRebootPassThru; Exit $LastExitCode }”

thank you


Hello guys,

anybody can help me?



I don’t think this is a psappdeploytoolkit issue. However I think you are running the .exe you download from SAP. Try extracting it with 7zip or similar first and then run nwsapsetup.exe like Baba suggests. That should do it.

If you have any customizations you want to perform (reducing the installed options for instance) then run nwsapsetupadmin.exe and create the payload there.

Does it work with PSADT alone but breaks when you have SCCM launch PSADT?

Here’s the line I’m using to deploy using PSADT 3.8.3
SAPGUI 7.40 base version

Execute-Process -Path "$dirFiles\SAPGUI_7_40_20160427_1449.exe" -Parameters "/silent" -IgnoreExitCodes '129'

Followed by SP11 install :

Execute-Process -Path "$dirFiles\gui740_11-10013011.exe" -Parameters "/silent" -IgnoreExitCodes '129'`

I don’t know where they could come up with this weird exit code…

RE: weird exit code
SAP installer was created in the 80s. They have such a monopoly in their field that they don’t care about modernizing their installer. They chose 129 years before MSI was an idea.

This is the command line I used on v7.4 3+years ago.

Execute-Process -Path "$dirFiles\gui740_11-10013011.exe" -Parameters "/silent /noDLG /ExtCMD=`"/Silent`" " -IgnoreExitCodes '129'`

If this doesn’t help, look in the SAP log files.

Good luck

thank you guys!

at the moment I am on vacation, when I return I will try what is suggested.