Deployment in SCCM 2012 R2 system account


I’m trying to deploy an application that I have wrapped in PSAppDeployToolkit. When I deploy it in the system context, then it dosent install the application. If I deploy it in the User context, then it installs the application.

Anybody that have experienced this?




If you try to run using PsExec as the system account with just the installer does the process also fail? I had one application that extracted to one location then tried to install from a different path causing the failures.

With testing with PsExec you can atleast find out if that is the issue you are facing. The command is psexec.exe -s \localhost “PathToYourExe”

I have just tried to run it with PSexec. When I run it in the system acount via PSexec, then it dosent get installed.

For my appllication Avaya One-X it was extracting the files to $envWinDir\System32\config\systemprofile\AppData\Local\Downloaded Installations\ as the system account. Then the installer was looking in $envWinDir\SysWOW64\config\systemprofile\AppData\Local\Downloaded Installations\ to run and since it was not there the installer would fail.

My work around was to grab the extracted files and in the script I copy them to the location that the installer is looking for them during the Pre-Installation section and then delete the files as part of the Post-Installation section.

Where did you see where the files was extraced?

The PSAppdeploytoolkit log file shows that the installathe exit with 0 (Success)


Ah well mine was erroring out; I did have one that acted like that and it was only installing to the system account and not all users. What type of file is the installer, exe or msi?

It is Microsoft CRM client. An exe file

I haven’t used that one myself so I’m not familiar with the details on it. The key is to figuring out what will make it install correctly from the system account; sorry I couldn’t be more help.

I Can deploy the exe file from sccm in the system context without any problems. So I guess it have something to do with psappdeploytoolkit.

Thanks for your suggestions Buster.


You have to set the toolkit to not require Admin rights.