Deploy-Application.exe not working right when running as a package from DP


I need a sanity check. I’m trying to deploy an application (Unreal Engine) which I created a PSAppdeploytoolkit wrapper script for which works if you run it manually from a UNC path. I’ve tested it running under the local\system context with a mapped drive letter using psexec. However when I create a package in SCCM 2012r2 CU5 to run with admin rights and use a drive letter it just flashes over to installed and nothing has been installed. The Deploy-Application.exe is listed as returning 0 success when I check the execmgr.log file.

I want to run it as an CM legacy package so I can install it from the DP share and not put another 8GB package in the cache to install a 16 GB application. I’ve only small 128GB SSD’s on the target machines I want to deploy this app to and I thought this would be the best way of doing it and minimise space use.

I’ve tried with toolkit version 3.6.8 and 3.6.7. Should this work and I’m doing it wrong or does it just not work like I think it does?

Any help appreciated.

I believe it will always return 0 unless you add the PassThru option.

Hi Brian

Thanks for the suggestion.
I’ll give it a go but that wasn’t how I understood the -AllowRebootPassThru worked. I thought (based on my reading of the documentation) it was to suppress the 3010 exit code to reboot, instead passing a exit code of 0. Otherwise the installers in the wrapper script would force SCCM to prompt for a reboot.

Putting -AllowRebootPassThru $false or $True didn’t make any difference.
I did notice that I had x64 in the architecture variable and the that the SCCM package was saying it was running it as a 32bit application. Not sure if that makes a difference. I’ve changed it to x86 and am retesting.

Nope still no change starting to doubt my sanity here. Has anybody else managed to use PSAppdeploytoolkit to install software via SCCM legacy package running from the DP Share?

I’ve never placed with Deploy-Application.exe but doesn’t run as system?
If so, on the network, System uses your computer account for access control.

Does your computer account have rights to your DP where your package lives?
Also, how does your computer account map the drive letter?
Seems like I’m not the only one having this trouble.
They make a good point about the SCCM client settings and PS-ExecutionPolicy. I did have it set to remote signed I’ve changed this and waiting to retry now.