Anaconda installs VERY slowly

I’ve noticed that some applications install very slowly with PSADT when building an image with MDT. Today the culprit is Anaconda. If I run the install directly from the same location that the task sequence uses, it takes just a few minutes. When run through PSADT it takes over an hour.

Execute-Process -Path 'Anaconda3-2023.09-0-Windows-x86_64.exe' -Parameters '/InstallationType=AllUsers /S'  -WindowStyle 'Hidden'

Have any of you run into this issue before? Any suggestions for troubleshooting? I build the images on a Hyper-V VM.


Maybe try to make the Anaconda installer create log files.

When you " install directly from the same location" do you run it as SYSTEM or elevated user?
When you " run through PSADT" do you run it as SYSTEM or elevated user?

When installing directly I run as admin through the right-click menu of the exe. When installing through the MDT task sequence using PSADT, I don’t make any specific changes from whatever is default. I assume that would be elevated.

I’ll look into creating the log files.

Thanks for your reply.

So you run as SYSTEM with PSADT.

If you " install directly from the same location" it probably extracts files to %temp%

When you run as SYSTEM, the SYSTEM profile has TWO %temp% folders.
One for 32bit processes and one for 64Bit processes.

I’m betting your Anaconda3-2023.09-0-Windows-x86_64.exe:
-runs as 64bit
-Extracts to the 64Bit %temp% folder
-Launches a 32bit process that looks for the extracted files in the 32bit %temp%
-The files it needs are not in the 32bit %temp% folder, they are in the 64Bit %temp% folder.

Thank you. I think I understand what you’re saying. I’m less clear about how I should solve it though. Would it be as simple as using Execute-ProcessAsUser instead of Execute-Process?

There are 2 ways to solve this:

  1. Extract Anaconda3-2023.09-0-Windows-x86_64.exe and launch the setup.exe directly.

  2. Temporarily merge the SYSTEM profile’s TWO %temp% folders. I had an idea on how to do this years ago but I forgot.

Since 7-zip is telling me “not implemented” when trying to extract the exe so I guess I’ll have try option 1. I’m familiar with the location of %temp%. Where would I find the other “%temp%” folder? Or is it application specific?

I did some digging.

I am wrong about the 2 Temp folders:
%Temp% for SYSTEM points to C:\Windows\Temp

HOWEVER, there are still 2 SYSTEM Profile locations:


Both Profiles have \AppData\ folders
and some installers will use the \AppData\ folder to extract installation files.

When the \AppData\ folder is used, it causes issues when running as SYSTEM.

Thank you again. I ran a couple of tests and it looks like either way the cache is created in C:\ProgramData\Anaconda3\Pkgs. I’ll look into the appdata folders to see what I can find tomorrow.