Toolkit fails with 0xC0000005(-1073741819)

Starting yesterday at around 1:00PM, all my packages created with PSADT have started failing when installed via SCCM with this error code: 0xC0000005(-1073741819)

No logs are created in c:\windows\logs\software. The only thing I see in the event log is a .net framework error.

Does anyone have any idea where to start troubleshooting this?



I should note that when I run direct from Powershell it works perfectly.

The fact that it works in the PowerShell console (Elevated console I assume), is proof that PSADT is not the problem.

If you search for error 0xC0000005, one of the results is this: Application Error (0xc0000005)
(TL;DR: Your Windows OS is broken)

If this is not this issue, you have an SCCM issue.
Try launching a simple PowerShell script with SCCM.
If that works, make the PowerShell script launch another PowerShell script or import functions from another file (aka Dot source)

Thanks for the suggestion. All my Patch My PC apps work and they use Powershell. I know it’s an SCCM issue. It is happening for every PSADT app I packaged. And on every machine. Any ideas?

No Ideas but since it worked before this means something has changed to break it.
Try to figure that out if you can.
If nothing is obvious, start rebooting SCCM servers…

I rebooted the entire SCCM infrastructure last night. Nothing changed in our environment that I know of. I had our night crew pushing manual updates to the operating rooms from Midnight to 6:00am yesterday. They had no problem. Then I started with the emergency room yesterday at 1:00PM and every machine failed.

I’m sorry I can’t help you.

I tell people: no PSADT log files in c:\windows\logs\software means PSADT did not get to run at all.

UPDATE: according to this older post: PowerShell - error - #23 by Philip_Bulinski

  • After a year and a part with a Microsoft case it was determined it is a PowerShell .Net error. It can be fixed but not permanently, the only real fix is to re-image the machine.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.