Show-InstallationRestartPrompt Cancelling itself

Hi all,

Trying to update our Imprivata Agent software across our enterprise, it needs a forced restart, but I need to be able to show this to the user and give them 15 minutes or so to action it.

The exit code from the install seems to cancel out the Show-InstallationRestartPrompt - I dont know why. I get the same problem in version 3.8.3 and 3.8.4 - code snippet from below is 3.83 - can anyone spot what I’m doing wrong please??

Have read up on some previous suggestions, nothing seems to have worked for me so far. it should be simple, right? :smiley:

Can I ignore exitcode on execute msi - The Toolkit / General Discussion - PSAppDeployToolkit Community

Code Below:
This script performs the installation or uninstallation of an application(s).
PowerShell App Deployment Toolkit - Provides a set of functions to perform common application deployment tasks on Windows.
Copyright (C) 2017 - Sean Lillis, Dan Cunningham, Muhammad Mashwani, Aman Motazedian.
This program is free software: you can redistribute it and/or modify it under the terms of the GNU Lesser General Public License as published by the Free Software Foundation, either version 3 of the License, or any later version. This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

The script is provided as a template to perform an install or uninstall of an application(s).
The script either performs an “Install” deployment type or an “Uninstall” deployment type.
The install deployment type is broken down into 3 main sections/phases: Pre-Install, Install, and Post-Install.
The script dot-sources the AppDeployToolkitMain.ps1 script which contains the logic and functions required to install or uninstall an application.
.PARAMETER DeploymentType
The type of deployment to perform. Default is: Install.
Specifies whether the installation should be run in Interactive, Silent, or NonInteractive mode. Default is: Interactive. Options: Interactive = Shows dialogs, Silent = No dialogs, NonInteractive = Very silent, i.e. no blocking apps. NonInteractive mode is automatically set if it is detected that the process is not user interactive.
.PARAMETER AllowRebootPassThru
Allows the 3010 return code (requires restart) to be passed back to the parent process (e.g. SCCM) if detected from an installation. If 3010 is passed back to SCCM, a reboot prompt will be triggered.
.PARAMETER TerminalServerMode
Changes to “user install mode” and back to “user execute mode” for installing/uninstalling applications for Remote Destkop Session Hosts/Citrix servers.
.PARAMETER DisableLogging
Disables logging to file for the script. Default is: $false.
powershell.exe -Command “& { & ‘.\Deploy-Application.ps1’ -DeployMode ‘Silent’; Exit $LastExitCode }”
powershell.exe -Command “& { & ‘.\Deploy-Application.ps1’ -AllowRebootPassThru; Exit $LastExitCode }”
powershell.exe -Command “& { & ‘.\Deploy-Application.ps1’ -DeploymentType ‘Uninstall’; Exit $LastExitCode }”
Deploy-Application.exe -DeploymentType “Install” -DeployMode “Silent”
Toolkit Exit Code Ranges:
60000 - 68999: Reserved for built-in exit codes in Deploy-Application.ps1, Deploy-Application.exe, and AppDeployToolkitMain.ps1
69000 - 69999: Recommended for user customized exit codes in Deploy-Application.ps1
70000 - 79999: Recommended for user customized exit codes in AppDeployToolkitExtensions.ps1
Param (
[string]$DeploymentType = ‘Install’,
[string]$DeployMode = ‘Interactive’,
[switch]$AllowRebootPassThru = $false,
[switch]$TerminalServerMode = $false,
[switch]$DisableLogging = $false

Try {
## Set the script execution policy for this process
Try { Set-ExecutionPolicy -ExecutionPolicy ‘ByPass’ -Scope ‘Process’ -Force -ErrorAction ‘Stop’ } Catch {}

## Variables: Application
[string]$appVendor = 'Imprivata'
[string]$appName = 'SSO Agent'
[string]$appVersion = ''
[string]$appArch = ''
[string]$appLang = 'EN'
[string]$appRevision = '01'
[string]$appScriptVersion = '1.0.0'
[string]$appScriptDate = '01/04/2022'
[string]$appScriptAuthor = ''
## Variables: Install Titles (Only set here to override defaults set by the toolkit)
[string]$installName = ''
[string]$installTitle = 'Imprivata SSO Upgrade - RESTART REQUIRED'

##* Do not modify section below
#region DoNotModify

## Variables: Exit Code
[int32]$mainExitCode = 0

## Variables: Script
[string]$deployAppScriptFriendlyName = 'Deploy Application'
[version]$deployAppScriptVersion = [version]'3.8.3'
[string]$deployAppScriptDate = '30/09/2020'
[hashtable]$deployAppScriptParameters = $psBoundParameters

## Variables: Environment
If (Test-Path -LiteralPath 'variable:HostInvocation') { $InvocationInfo = $HostInvocation } Else { $InvocationInfo = $MyInvocation }
[string]$scriptDirectory = Split-Path -Path $InvocationInfo.MyCommand.Definition -Parent

## Dot source the required App Deploy Toolkit Functions
Try {
	[string]$moduleAppDeployToolkitMain = "$scriptDirectory\AppDeployToolkit\AppDeployToolkitMain.ps1"
	If (-not (Test-Path -LiteralPath $moduleAppDeployToolkitMain -PathType 'Leaf')) { Throw "Module does not exist at the specified location [$moduleAppDeployToolkitMain]." }
	If ($DisableLogging) { . $moduleAppDeployToolkitMain -DisableLogging } Else { . $moduleAppDeployToolkitMain }
Catch {
	If ($mainExitCode -eq 0){ [int32]$mainExitCode = 60008 }
	Write-Error -Message "Module [$moduleAppDeployToolkitMain] failed to load: `n$($_.Exception.Message)`n `n$($_.InvocationInfo.PositionMessage)" -ErrorAction 'Continue'
	## Exit the script, returning the exit code to SCCM
	If (Test-Path -LiteralPath 'variable:HostInvocation') { $script:ExitCode = $mainExitCode; Exit } Else { Exit $mainExitCode }

##* Do not modify section above

If ($deploymentType -ine 'Uninstall' -and $deploymentType -ine 'Repair') {
	[string]$installPhase = 'Pre-Installation'

	## Show Welcome Message, 
	Show-InstallationWelcome  -AllowDefer -DeferTimes 7 -DeferDeadline '31/05/2022' -PersistPrompt

	## Show Progress Message (with the default message)
	Show-InstallationProgress -StatusMessage "Screen and Desktop Icons may flicker... This installation may take up to 15 minutes to complete."

    #test for pending reboot
    $reboot = Get-PendingReboot

    if($reboot.IsSystemRebootPending -eq $true -or $reboot.IsCBServicingRebootPending -eq $true -or $reboot.IsWindowsUpdateRebootPending -eq $true -or $reboot.IsSCCMClientRebootPending -eq $true -or $reboot.IsFileRenameRebootPending -eq $true)
            #reboot pending, cannot proceed.
            Show-InstallationPrompt -Message "A reboot is pending on this machine. Please reboot this machine first before installing $installTitle" -ButtonRightText 'OK'
            Exit-Script -ExitCode 69004 #this code to indicate a reboot is pending on this machine, and installation cannot proceed.
	## <Perform Pre-Installation tasks here>
	Execute-Process "taskkill" -Parameters "/im ISXAgent.exe /f" -IgnoreExitCodes '128'
	Execute-Process "taskkill" -Parameters "/im ISXAgent64.exe /f" -IgnoreExitCodes '128'
	Stop-Process -Name "SSOManHost" -Force
	Stop-Process -Name "SSOWOW64Bridge" -Force

	[string]$installPhase = 'Installation'

	## <Perform Installation tasks here>
    # Using passthrough to blank out the 3010 response we get from installing the MSI
    $ExecuteMSIresult = Execute-MSI -Action Install -Path "$dirFiles\ImprivataAgent_x64.msi" -Parameters 'IPTXPRIMSERVER="<redacted>/sso/servlet/messagerouter" AGENTTYPE="1" MIGRATE_SETTINGS=FALSE /QN /NORESTART' -PassThru
    Clear-Variable $ExecuteMSIresult

	[string]$installPhase = 'Post-Installation'

	## <Perform Post-Installation tasks here>
    Set-RegistryKey -Key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" -Name "DefaultDomainName" -Value "xfph-tr" -Type String 

	#Prompt for a restart (if running as a user)
	#If (($mainExitCode -eq 0) -OR ($mainExitCode -eq 3010)) {
	Show-InstallationRestartPrompt -CountdownSeconds 6000 -CountDownNoHideSeconds 6000

ElseIf ($deploymentType -ieq 'Uninstall')
	[string]$installPhase = 'Pre-Uninstallation'

	## Show Welcome Message, close Internet Explorer with a 60 second countdown before automatically closing
	Show-InstallationWelcome -CloseApps 'iexplore' -CloseAppsCountdown 60

	## Show Progress Message (with the default message)

	## <Perform Pre-Uninstallation tasks here>

	[string]$installPhase = 'Uninstallation'

	## Handle Zero-Config MSI Uninstallations
	If ($useDefaultMsi) {
		[hashtable]$ExecuteDefaultMSISplat =  @{ Action = 'Uninstall'; Path = $defaultMsiFile }; If ($defaultMstFile) { $ExecuteDefaultMSISplat.Add('Transform', $defaultMstFile) }
		Execute-MSI @ExecuteDefaultMSISplat

	# <Perform Uninstallation tasks here>

	[string]$installPhase = 'Post-Uninstallation'

	## <Perform Post-Uninstallation tasks here>

ElseIf ($deploymentType -ieq 'Repair')
	[string]$installPhase = 'Pre-Repair'

	## Show Progress Message (with the default message)

	## <Perform Pre-Repair tasks here>

	[string]$installPhase = 'Repair'

	## Handle Zero-Config MSI Repairs
	If ($useDefaultMsi) {
		[hashtable]$ExecuteDefaultMSISplat =  @{ Action = 'Repair'; Path = $defaultMsiFile; }; If ($defaultMstFile) { $ExecuteDefaultMSISplat.Add('Transform', $defaultMstFile) }
		Execute-MSI @ExecuteDefaultMSISplat
	# <Perform Repair tasks here>

	[string]$installPhase = 'Post-Repair'

	## <Perform Post-Repair tasks here>


## Call the Exit-Script function to perform final cleanup operations
Exit-Script -ExitCode $mainExitCode

Catch {
[int32]$mainExitCode = 60001
[string]$mainErrorMessage = “$(Resolve-Error)”
Write-Log -Message $mainErrorMessage -Severity 3 -Source $deployAppScriptFriendlyName
Show-DialogBox -Text $mainErrorMessage -Icon ‘Stop’
Exit-Script -ExitCode $mainExitCode

wow, this is an interesting one. I wish you would have formatted with </> but I think I figured out your code anyhow.

I looked in the Show-InstallationRestartPrompt function and this is the code causing that weird message:

		## Check if we are already displaying a restart prompt
		If (Get-Process | Where-Object { $_.MainWindowTitle -match $configRestartPromptTitle }) {
			Write-Log -Message "${CmdletName} was invoked, but an existing restart prompt was detected. Cancelling restart prompt." -Severity 2 -Source ${CmdletName}

Given that PSADT relaunches itself to display popups that last beyond the install such as Show-InstallationRestartPrompt, it makes sense to have this in as a fail safe.

Since $configRestartPromptTitle = ‘Restart Required’ in the XML, it would seem that another instance of PSADT is running to show a reboot prompt. Maybe it’s hidden or half-crashed.

Yeah sorry it was very much a copypasta fail when I tried to upload the code…

Another instance of PSADT with the same window being displayed? huh. I checked and its the only occurrence of Show-InstallationRestartPrompt in the toolkit. Perhaps its something specific to the Imprivata application which causes it. I will try the same code with a different application, see if thats the case.

thanks for looking :slight_smile:

Plug this just before you call Show-InstallationRestartPrompt:

$allProcesses = Get-Process
$allWindowTitles=$allProcesses | Select id,name,MainWindowTitle | where { $_.MainWindowTitle -ne '' }
Write-log $allWindowTitles|out-string

It might show which process causing your problem.

Hey Not-So-Annoying-Guy,
This isn’t germane to just this post but I thought I’d take this opportunity…

I always read these posts, even when the particular question refers to features of PSADT that I don’t use (never have and probably never will use Show-InstallationPrompt), because I’m always on the lookout for interesting tips/tricks.

You’re always here, chiming in with good info even when it appears to take a fair bit of effort to parse the question. I just wanted to say, “Thanks! Your efforts are much appreciated.”

So… Thanks! Your efforts are much appreciated. As is the awesome PSADT!



Thank you for your support. I try to help as much as possible because I still remember the frustrations of getting stuff to almost work but can’t because PSADT/PS/.Net is so damn big. I’ve learned a lot by just reading the code in the main ps1. I really appreciate being noticed for my efforts.


Amazing Mr Guy. You led me to the answer, and its totally true what the other poster said about you, you are an asset to this community.

so the answer was literally staring us in the face. I put the text “Restart Required” in the [string]$installTitle = ‘Imprivata SSO Upgrade - RESTART REQUIRED’ of the code because I wanted the prompt to be prominent to the end user that a restart would occur. As soon as I removed this bit of text and updated it everything works as expected.

thanks again Internet Stranger, really good to know I have that fixed.

1 Like

Thank you very much.

BTW: you might still be able to put “RESTART REQUIRED” back in via pig latin:

you get the idea.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.