Installing Backup Exec agent and some first timer questions

I’m looking to call this with MDT once I get it working, but for testing I’m just invoking Deploy-Application.ps1 from PowerShell manually. I’ve read most of the admin manual and an online beginner guide, but I still have a few questions. For my first install I’m trying the Backup Exec agent. I looked at the msi log that Backup Exec creates when you do a push install using their console. It shows this for their parameters:

MSI Command Line: EXE_ENVOKED=1 ALLUSERS=1 REBOOT=ReallySuppress INSTALLDIR=“C:\Program Files\Veritas\Backup Exec\RAWS” INSTALLLEVEL=200 ADDLOCAL=ALL TRANSFORMS=“C:\ProgramData\Veritas\Backup Exec{01FA58EE-0136-4113-92E4-AD555504BA41}\1033.MST” PATCH=“C:\BEW-a7226352d6634a3d9b45a07b44461558\VxPushRA\RAWSX64\Updates\RAWSx641188RHF525537.msp;C:\BEW-a7226352d6634a3d9b45a07b44461558\VxPushRA\RAWSX64\Updates\RAWSx641188RSP.msp;” REINSTALLMODE=emus RAWSADVRTISENAMELIST=SERVER1; ENABLEADVRT=1 VMWAREGUEST = 0 INSTALLUIMODE=0 CERT_BLOB=BLOB

I added most of these to my MST and here’s my command

Execute-MSI -Action ‘Install’ -Path ‘Veritas Backup Exec Remote Agent for Windows Systems.msi’ -transform ‘Veritas Backup Exec Remote Agent for Windows Systems.mst’ -AddParameters “RAWSADVRTISENAMELIST="SERVER1”"

A few questions:

  1. Do I need to comment out the section for “Handle Zero-Config MSI Installations” when I’m going to specify my own Execute-MSI command? Even if I do comment out that section I’m finding it still installs the patches I have in the installation directory. I do want the patches installed, but not sure how they’re getting called at this point since I’m not specifying them in my command.
  2. As shown above, there are two patches that go with this. The first patch installs successfully with reboot pending. The second patch fails with a generic 1603 return code. I can’t find any meaningful reason in the logs.
  3. I have an MST I created, but when I look at the Property table in the MSI I don’t see the property RAWSADVRTISENAMELIST. Not sure why. This is why I tried adding it as a parameter to my Execute-MSI command. If I could get it in the MST then I would probably just use the zero config deploy. I guess I could try just adding a new row in the MST Property table for it, but I also feel like I should be able to add it as a parameter like I am. I see no evidence in the installations logs that this property is getting specified the way I’m currently doing it.
  4. I saw some references to SCCM integration. Does it load Microsoft.SMS.TSEnvironment automatically so I can eventually get access to the MDT variables? I wasn’t sure so I added steps to do that in PRE-INSTALLATION section, but so far I’m not using any MDT variables.

I think that’s it for now. Thanks in advance.

It seems the html editor changed what I entered for the install command. I’m escaping with a backtick before each double quotes around SERVER1.

I found that I could put the RAWSADVRTISENAMELIST in the property table in my transform. If I do it gets applied correctly. Not sure why I can’t add it in the deploy script with -AddParameters

Just to confirm the patches work okay I just tested copying the \Files folder locally and executing this command. Everything installed correctly without any errors:

msiexec /i “c:\files\Veritas Backup Exec Remote Agent for Windows Systems.msi” REBOOT=ReallySuppress TRANSFORMS=“c:\files\Veritas Backup Exec Remote Agent for Windows Systems.mst” ALLUSERS=1 /qb- /l*vx “c:\BackupExecAgent.log” PATCH=“c:\files\RAWSx641188RHF525537.msp;c:\files\RAWSx641188RSP.msp;”

The difference is I’m applying both patches at install time. It looks like Deploy-Application.ps1 doesn’t do that. It installs the MSI and then does two separate msiexec.exe /update commands - one for each patch. This seems to cause it to fail.

to install patches you will need to do it in a separate line. like.

## Install the base MSI and apply a transform
Execute-MSI -Action Install -Path 'Adobe\_Reader\_11.0.0\_EN.msi' -Transform 'Adobe\_Reader\_11.0.0\_EN\_01.mst'
## Install the patch
Execute-MSI -Action Patch -Path 'Adobe\_Reader\_11.0.3\_EN.msp'

as per the quotes. that’s a problem I have ran into
check this out.

in this post, there is a reference on where to place the quotes as well some silly problemes that you can run into.

Hmm…I’m not sure how that post applies to me. I’m not putting a variable in single quotes. I think the only quoting problem I was having is showing it on this web page.

ok, weird I was refering this part.

#Since -Parameters and -AddParameters are string arrays you can specify one string like this:
Execute-MSI -Action Install -Path 'NameofMSIFile.msi' -Parameters "PROPERTY=`“value`” PROPERTY2=`“value`”"
#Or an array like this:
Execute-MSI -Action Install -Path 'NameofMSIFile.msi' -Parameters "PROPERTY=`“value`”", "PROPERTY2=`“value`”"

not sure if you have tried adding the patching in the parameters too with the proper quotes.
well, you are not getting an error. what is the log telling you?

The patches are getting installed automatically I assume by the zero config feature. It seems like the zero config feature would not be used if you specify a command manually which goes back to my question #1.
I’m not calling the updates in my install command as you can see. The second patch does generate the 1603 error I mentioned. As for the quotes I’m specifying them the same way you’re showing for the public property I was trying to add.

ah! it sounds that there is a setting somewhere else inside your installer then. or at least that’s what I’m now understanding.
what happens if you run the installer by it-self without doing the transform?
if you still get the patches then I would assume you need to look for a .inf or some other file giving additional properties that targets the patches. like I would say. not a virgin install.
that would mean that there is an admin tool for the installer and you need to open the transform file with that toll and see what is doing.
or try deleting the .inf and the transform file and test it see if that makes it “virgin”

I see no .inf file in the \Files directory. The original transform file was generated by Backup Exec. If I remove the transform file it fails to find dll files that are in the \Files directory and fails the install.

I’d really like to get some of the questions answered from my original post. Questions #1 and #4 would be nice to know please.