Error when running PSADT script

Hi all

Newbie here so apologies in advance if this is something very simple.
I have customised the ADT Deploy-Application.ps1.
Installing CitrixWorkspaceApp.exe

	## <Perform Installation tasks here>
    $FileName = .\Files\CitrixWorkspaceApp.exe /silent /includeSSON /AutoUpdateCheck=disabled -wait

When running the above selection in PS it runs fine and as expected.

When running the ADT - Deploy-Application.exe I get the following error (after the initial welcome screen asking to defer or continue):

Any suggestions

I have entered the full path of file which seems to have done the trick.

As I am not using start-process I cannot end with -wait.
How can I delay the script from moving to the next stage only when the application has been installed.

So I have added the Start-Sleep -seconds 100

It all works as I expected now.

Not sure if I have done things the correct/right way though so any advice would be greatly appreciated.
Below is what I have used to run the .exe with switch commands and then wait 100 seconds before ADT moves on to displaying the install is complete.

	## <Perform Installation tasks here>
    $FileName = C:\temp\CitrixWorkspaceApp.exe /silent /includeSSON /AutoUpdateCheck=disabled -wait
    Start-Sleep -Seconds 100

Put the .exe into the Files directory. Then use

Execute-Process -Path "$dirFiles\CitrixWorkspaceApp.exe" -Parameters "/silent /includeSSON /AutoUpdateCheck=disabled"

in Deploy-Application.ps1. More documentation can be found inside the PDF that is included in the release or we have a wiki
You can also take a look at community made guide: Great beginners guide to PSAppDeployToolkit

That’s saved me an extra command of copying the install file to the local clients temp folder.

Do I still use the Start-Sleep command to let the install finish? or is there something I can use like the -wait command.

I will check out the PDF.

No, Execute-Process waits by default. Can specify -NoWait if you dont want it to wait.
The toolkit also creates its own log. Settings are inside the config file.