Deploying Jetbrains Toolbox Intune

Hey all, I’m attempting to use PSAppDeployToolkit to install JetBrains Toolbox via Intune. This is a user based application and installs in C:\Users%username%\AppData\Local\JetBrains\Toolbox\bin.

I’m using the following command to install Execute-Process -Path "$dirFiles\jetbrains-toolbox-1.25.12627.exe" -Parameters "/S" and using the run as user option in Intune.

I’m also running the following lines to create a shortcut because it doesn’t appear to create one automatically.

New-Shortcut -Path "$Home\Desktop\Jetbrains Toolbox.lnk" -TargetPath "C:\Users\$env:UserName\AppData\Local\JetBrains\Toolbox\bin\jetbrains-toolbox.exe" -IconLocation "C:\Users\$env:UserName\AppData\Local\JetBrains\Toolbox\bin\jetbrains-toolbox.exe" -Description 'Jetbrains Toolbox' -WorkingDirectory "C:\Users\$env:UserName\AppData\Local\JetBrains\Toolbox\bin\"

When I run AppDeploy.exe locally Jetbrains Toolbox installs flawlessly, however when attempting to install the app through Company Portal the install downloads and a UAC prompt appears assuming something in the script requires admin permissions to run.

I have tried running the installer using execute-ProcessAsUser and selecting the option to install as System in Intune but nothing installs at all and detection fails.

Has anyone had a similar experience that can provide some suggestions?

Thanks in advance!

I’m suspecting the profile it is installing into is not what you are expecting.
Look in the PSADT log file for “Display session information for all logged on users:”
Below it you’ll something like:

NTAccount           : CONTORSO\Peter.Smith
SID                 : S-1-5-21-<Censored>
UserName            : Peter.Smith
DomainName          : CONTORSO
SessionId           : 6
SessionName         : Console
ConnectState        : Active
IsCurrentSession    : True
IsConsoleSession    : True
IsActiveUserSession : True
IsUserSession       : True
IsRdpSession        : False
IsLocalAdmin        : False
LogonTime           : 2022-07-26 9:28:52 AM
IdleTime            : 23:28:41.7929711
DisconnectTime      : 2022-07-25 6:09:17 PM
ClientName          : 
ClientProtocolType  : 
ClientDirectory     : 
ClientBuildNumber   : 0

[07-26-2022 17:45:08.843] [Initialization] [PSADT] [Info] :: The following users are logged on to the system: [CONTORSO\Peter.Smith].
[07-26-2022 17:45:08.848] [Initialization] [PSADT] [Info] :: Current process is running with user account [NT AUTHORITY\SYSTEM] under logged in user session for [CONTORSO\Peter.Smith].
[07-26-2022 17:45:08.852] [Initialization] [PSADT] [Info] :: The following user is the console user [CONTORSO\Peter.Smith] (user with control of physical monitor, keyboard, and mouse).
[07-26-2022 17:45:08.858] [Initialization] [PSADT] [Info] :: The active logged on user is [CONTORSO\Peter.Smith].
[07-26-2022 17:45:08.862] [Initialization] [PSADT] [Info] :: The active logged on user [CONTORSO\Peter.Smith] has a primary UI language of [EN]

In this case, Execute-ProcessAsUser would be using Peter.Smith’s profile But Peter.Smith better be logged-in at install time for this to work.

Also for Execute-ProcessAsUser to work, it needs to create a Scheduled Task to run AS THE USER. If PSADT can’t create the task, it won’t work.

Another solution is repackaging it. This guy used MSI but you can also use PSADT exclusively to install your CrapApp:
Depending on your skill level, you’ll probably will have to change the registry entries to point to \Program Files\ or \ProgramData\.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.