I’m trying to work out whether you’re agreeing with me or having a go at me
. Let’s try and break it down.
Regrettably, our toolkit even in the v3 days has had an option called -AllowRebootPassThru, whereby in its default state, a nominated reboot code does not get returned; instead returning 0. We don’t believe this is the right approach anymore and seek to change it, however people may be relying on that behaviour, rightly or wrongly, hence the suggestion of an opposing switch to replace it which does the opposite.
I believe we’re in complete agreement here, hence why we’re trying to right the wrongs of the past for the benefit of not just yourself, but the wider community.
Far from it. By virtue of the name, the -AllowRebootPassThru switch only supresses the return of an exit code that’d tell MECM, Intune, or other software that an app deployment requires a reboot. A failing exit code will always be returned when an error occurs, either the app installer’s own exit code or one of our generic ones in the event of a script typo, etc.
I believe you’ve got a huge misunderstanding about what’s being talked about here and as such, I’d refer to you to the previous quote reply in this post I’m writing to you now. I will say it again, v4, like v3, will return an error code at all times when a deployment fails unless you as the packager go out of your way to suppress. The only thing v4 suppresses is the same thing that v3 suppresses by default, reboot exit codes.
There shouldn’t be anything in-particular to glean as the behaviour in this regard is 1:1 with v3 and it was very deliberate to make v4 maintain the core of what makes PSAppDeployToolkit the solution everyone’s come to know and love. We absolutely welcome documentation suggestions or improvements from the comunity and want to make sure you’ve got the information necessary to feel empowered with your deployments. On the initial release of v4, some of our documentation did not meet our own standards which we apologise for. I can only offer excuses, however the refactoring that’s gone into making v4 was no small undertaking and in trying to deliver a first class product among sacrificing personal time with our family, friends, and loved ones to deliver the product for free, the quality of documentation did slip in that process.
I’m unsure whether you’ve used v4 yet, however you yourself can download our latest template, add a line akin to Start-ADTProcess -FilePath cmd.exe -ArgumentList '/c "exit 1234"' and observe your deployment will fail and exit out with an exit code of 1234. That truly is package management 101 and nothing’s slipped there.