PSADT 3.8.2 - ProcessAsUser error

Hi again,
If this has already been mentioned, forgive me again.
I ran into the following problem:
This is running perfectly with PSADT 3.8.1:
Execute-ProcessAsUser -UserName $person -Path “$envWinDir\SysWOW64\WindowsPowerShell\v1.0\powershell.exe” -Parameters “-executionpolicy bypass -WindowStyle Hidden -File $DirFiles\New-AovpnConnection.ps1 -xmlFilePath $DirFiles\ProfileXML_User_CHU.xml -ProfileName AOVPN-Users -AllUserConnection” -Wait $true -runlevel HighestAvailable

The same command with PSADT 3.8.2 results in:
[06-24-2020 09:20:37.261] [Installation] [Execute-ProcessAsUser] :: The specified working directory does not exist or is not a directory. The scheduled task might not work as expected.

Thanks for your help

-Wait is a switch not a boolean and version 3.8.2 comes with a new parameter -WorkingDirectory which is where $true was passed in. No such directory exists so the task failed. In the previous version this parameter didnt exist so the $true was passed into the parameter -ContinueOnError which is a boolean so it worked. Basically, you got lucky previously.

Thanks again… I didn’t notice this change in the documentation… Sorry again for bothering you
EDIT: I don’t find this in the current documentation which is still in 3.8.1 version.
Where should I use

-WorkingDirectory
Execute-ProcessAsUser -UserName $person -Path "$envWinDir\SysWOW64\WindowsPowerShell\v1.0\powershell.exe" -Parameters "-executionpolicy bypass -WindowStyle Hidden -File $DirFiles\New-AovpnConnection.ps1 -xmlFilePath $DirFiles\ProfileXML_User_CHU.xml -ProfileName AOVPN-Users -AllUserConnection" -Wait -runlevel HighestAvailable

The documentation was not updated. We will update it for the next version.
You dont have to use -workingDirectory at all unless that application needs it.
Can also add it to the end: -WorkingDirectory