Pre-Installation Uninstall Issue. MainEngineThread Error 1605

Hello everyone!

App= IAM Cloud Drive Mapper.

I am trying uninstall any version of IAM Cloud Drive Mapper and install the new version.
I keep receiving this error message

Error 1605: ‘This action is only valid for products that are currently installed’

This isn’t message isn’t right. The product IS installed and the Uninstall keys all match up in the registry.

I haven’t seen this before but if I install an old version of this application with a non admin user and run the script it will remove the app as expected and install the new one no problems.

If I install the old version of this application with an administrative user and run the script it will remove the app as expected and install the new one no problems.

My problem is if I install the app let’s say as the admin and log in as the user it will not work. (Or vice versa) It seems to only like to uninstall the app if it was the original user that installed it.

This is a problem because this app has been installed by many different users / local IT / at all different locations. There is no way I can isolate it.

How can I go about saying it doesn’t matter who installed what just remove this app?

Thanks!

Have you tried using ALLUSERS property?
ALLUSERS property - Win32 apps | Microsoft Docs

Good idea I haven’t tried that yet.
How could I incorporate that into the Remove-MSIApplications command?
I didn’t see that as a parameter option?

How many GUIDs/MSIs are you uninstalling?

Unfortunately it is many versions and I don’t have all the MSI’s available.

Remove-MSIApplications does support -Parameters and -AddParameters. If you have default MSI parameters in your XML config then use -AddParameters to append to them. -Parameters will replace the xml parameters.

Ok so I am not using an XML file but i would do a remove-msi applications -name ‘cloud drive mapper’

  • add parameters file.xml

That would contain:

<Property Id="ALLUSERS" Secno"/>
<Condition Message="Setting the ALLUSERS property is not allowed because [ProductName] is a per-user application. Setup will now exit.">
  NOT ALLUSERS
</Condition>

no our toolkit has an xml config file with default MSI parameters it uses. i meant that file

My apologies that is right. I had to use it to change the Toolkit_RequireAdmin to False actually. Which section would the Above go in?

<MSI_Options>

These are used only if you don’t use -Parameters to replace them. Can either modify those or use -AddParameters to append to them in the code.