AirWatch\Workspace ONE

Does anyone have any experience with using psappdeploytoolkit for app package deployment within AirWatch/Workspace ONE to Windows 10 devices? I have been using it in our environment for a while and we have ran into issues here and there, but I wanted to see if there were others.

Hi Adam,

we have tried to use the PSAppDeployToolkit in our WSO environment, but we are failing because there is no user interaction when installing an application.

The log says:
Session 0 detected, process not running in user interactive mode; deployment mode set to [NonInteractive]

We’ve also tried to run the instalation with the ServiceUIx64.exe, but in this case even the application gets not installed. :slightly_frowning_face:

Do you have any idea what we’re doing wrong?


We have been using the toolkit with Workspace ONE and Windows 10 devices for about two years now with only minor issues. Most of our installs are without user interaction anyway and the ones that do need interaction one of the guys here wrote a function to make it interactive if there is a user logged in.

The biggest issue we have is VMWare stating that the toolkit is ‘not native’ and to ingest using just the base MSI instead.

1 Like

Hi tregelen, May I learn the jist of the function from you, to make it interactive if there is a user logged in? Do you keep in in the tookitmain.ps1? I’m about to dive into workspace one soon…