zenworks problem

hi

i am using zenworks to deploy software…
but it cuases an error…

zenworks execute this powershell script on the users computer…

<code>$pw= convertto-securestring &quot;password&quot; -asplaintext –force
$pp = new-object -typename System.Management.Automation.PSCredential -argumentlist &quot;.\Administrator&quot;,$pw
Start-Process powershell -Credential $pp -ArgumentList &#039;-ExecutionPolicy Bypass -file \\share\Office2013\install.ps1 -verb runas -wait&#039;</code>

install.ps1:
Start-Process "$PSHome\PowerShell.exe" -Verb RunAs -ArgumentList ' -ExecutionPolicy Bypass -file \share\MSOffice2013\Deploy-Application.ps1' -Wait

logfile generates the following error code:
<![LOG[[Pre-Installation] :: Standard error output from the process: \share\Office2013\Files\OffScrub13.vbs(3023, 9) SWbemObjectEx: Access Denied.

tried to execute the Deploy-Application.exe and ps1 file direct from zen but also generates the same error.

here is my deploy-application.ps1
https://gist.githubusercontent.com/LadyViktoria/2d365c04e6cf6bc342a93c531da13ea7/raw/b15f0fd67714878b338b859852478e329a8485f6/gistfile1.txt

running install.ps1 from admin powershell works fine also the *.exe works fine from admin powershell on my test environment.

think i have got it working :slight_smile:

Execute-Process -Path “cscript.exe” -Parameters “”$dirFiles\OffScrub13.vbs" ALL /S /Q /NoCancel" -WindowStyle Hidden -IgnoreExitCodes ‘1,2,3’ -CreateNoWindow

-CreateNoWindow was the key :slight_smile: