MSI Installations Problem

Hello. I have problems with Installation of MindManager 16. When i install the MSI directly, it works fine. If i try to install within the wrapper via Execute-MSI or Execute-Process the Software not working. There seems to be some problems with Custom Actions where register many DLL’s. I cannot find out, what the problem is. The problem appears only if the MSI installed within the wrapper. Is absolutelly not matter who or what triggers the Wrapper (System Acc or Admin Acc). I tried manually triggering with the Deploy-Application.exe or Deploy-Application.ps1, tried to install with SCCM, always got the same problem.

Hi Alex,
This is an MSI issue. However, I’ll do my best to provide some advice, since there are a lot of variables.

A few different scenarios come to mind as possible issues:

  1. The most likely scenario is that using a silent switch to install the application affects the feature levels of the MSI. You can test this by running the install with the silent switch while logged into the machine and see if you’re still getting this issue. If this is the issue, you’ll want to use an MSI editor to change the install level property.
  2. There are properties that are not being set when the application is silently in an automated fashion.
  3. There are custom actions which only run during the UI phase of installation
  4. When you push the installation out to your clients, they might have an older version of the application. If there is an older version of the application which matches a target upgrade code in the upgrade table, the upgrade flags could be causing the new install to copy the install state for the older version of the application. I’ve seen these install states be set to null very frequently.

I actually just finished building a Mindjet MindManager 2016 deployment. Are you doing this from the Admin MSI provided from your sales representative?