Microsoft DirectAccess Connectivity Assistant Tool 2.0


First time posting here.

I am trying to deploy the DirectAccess Connectivity Assistant Tool 2.0 and I am having issues. Deploying the standalone .msi from SCCM was problematic (I don’t exactly remember why) so I ended up going with the following logic in a stand package …

“wusa.exe dcu.exe /quiet /norestart”

In the above example, dcu.exe is extracted from the application .msi.

I am using the Toolkit because I am uninstalling the 1.5 version of the application prior to installing the newer version. I tried using the standalone .msi from within the Toolkit and, even with the /qn switch, it still forces a reboot.

I then tried the following logic …
Execute-Process -FilePath “wusa.exe” -Parameters “$dirFiles\Dca.msu /quiet /norestart”

But upon execution, it only brings up the wusa.exe extension menu as if I used the /help switch.

Any ideas to get this to work?


At the advice on another thread found HERE I attempted the following logic unsuccessfully …

Execute-Process -FilePath “wusa.exe” -Parameters “/s /f1^”$dirFiles\Dca.msu /quiet /norestart^””

My guess is its because wherever Dca.msu is stored that path has a space in it.

I’m struggling with this as well, because it’s getting passed to the command prompt and terminating at the space in the pathway.